Τετάρτη
05/09/2018

Η Google θα αλλάξει τη συμβατότητα των εφαρμογών στο Android Q

androidpie statue

Η Google προσπαθεί να ελαττώσει τις επιπτώσεις του Android fragmentation με το να προτρέπει τους developers να σταματήσουν την υποστήριξη παλαιότερων εκδόσεων του λειτουργικού συστήματος, κάτι το οποίο θα γίνει πιο έντονα στο Android Q.

Οι προσπάθειες που έχει ξεκινήσει να κάνει η Google έχουν να κάνουν με τη νέα πολιτική που θέλει να εφαρμόσει στο Google Play Store, όπου οι νέες εφαρμογές θα πρέπει να είναι συμβατές με το Android 8.0 Oreo αλλά και νεότερες εκδόσεις, κλείνοντας την “πόρτα” στις παλαιότερες. Το ίδιο θα γίνεται και στις αναβαθμίσεις των εφαρμογών που υπάρχουν ήδη στο Play Store, με τους developers να έχουν το δικαίωμα να επιτρέψουν τις εφαρμογές να “τρέχουν” σε εκδόσεις παλαιότερες του Android 8.0 Oreo.

Σύμφωνα με το XDA forums, η Google θα φέρει αλλαγές στην έκδοση Android Q μιας και θα αλλάξει τη μικρότερη συμβατή έκδοση των εφαρμογών από το Android 4.2 Jelly Bean (API level 17) σε Android 6.0 Marshmallow (API level 23), κάτι που σημαίνει ότι κάθε φορά που οι χρήστες θα “κατεβάζουν” μια εφαρμογή για smartphone με Android 5 Lollipop αλλά και παλαιότερη έκδοση του λειτουργικού συστήματος, θα λαμβάνουν προειδοποίηση πως η εφαρμογή δεν είναι συμβατή με τη συσκευή τους.

Παρά την ειδοποίηση, η εφαρμογή θα συνεχίσει να λειτουργεί χωρίς όμως κανένας να εγγυάται την ομαλή λειτουργία της, μιας και δε θα έχει τα ίδια επίπεδα ασφαλείας και ιδιωτικότητας που εμφανίστηκαν στο Android 6.0 Marshmallow. Τέλος, ένας λόγος για τον οποίο η Epic Games δεν έκανε διαθέσιμο το Fortnite στο Google Play Store, πέραν των μειωμένων κερδών που θα είχε μιας και θα έπρεπε να δώσει το 30% στη Google, είναι το ότι οι εφαρμογές στο Play Store δίνουν συμβατότητα μέχρι την έκδοση Android Lollipop.

Δε θα πρέπει όμως να ξεχνάμε πως η κίνηση αυτή από την Epic Games έφερε σοβαρό κενό ασφαλείας στην εγκατάσταση του Fortnite, με τη Google να ελπίζει πως τέτοια προβλήματα δε θα προκύψουν στην επόμενη έκδοση του Android.

Πηγή

Μάθε για: ,

Συντάκτης: .

3 Σχόλια

  1. Ο/Η NikosAr λέει:

    Και γιατί εφόσον δεν είναι συμβατή με την έκδοση λειτουργικού … απλά να σταματά η εγκατάσταση και να μην έχουμε δικαιολογία για τα κενά ασφαλείας ;

  2. Ο/Η Agnostos13 λέει:

    @NikosAr:

    Γιατί θα μείνουν πολλοί ξεκρέμαστοι…
    Και μην κοιτάς μόνο τα smartphones!
    Σκέψου να πάρει κάποιος android car headunit που θα πάρει update πρακτικά ποτέ. Να έχει δώσει 600-700 με την εγκατάσταση. Και μετά από 2 χρόνια να μην μπορεί να κατεβάσει εφαρμογή. Ουσιαστικά έχει πετάξει τα λεφτά του (εκτός αν είναι όλη μέρα στο αμάξι οπότε έχει κάνει απόσβεση).

  3. Ο/Η BILL5DS λέει:

    Δουλεύουνε ψιλό γαζί και εμείς τους τα ακουμπάνε κανονικα

Η γνώμη σας

Παρακαλούμε σχολιάστε με ελληνικούς πεζούς χαρακτήρες, όχι greeklish.

Πατώντας "Αποστολή" αποδέχεστε τους Όρους Χρήσης.